Uploaded image for project: 'core.rrb-vector'
  1. CRRBV-18

core.rrb-vector fails on JDK 11 EA builds

    Details

      Description

      I tried to test boot on JDK 11 EA builds and there seems to be fipp somewhere in the dependency chain that has core.rrb-vector 0.0.11 as dependency. It fails with the below error :

      java.lang.IllegalArgumentException: Must hint overloaded method: toArray
      clojure.lang.Compiler$CompilerException: java.lang.IllegalArgumentException: Must hint overloaded method: toArray, compiling:(clojure/core/rrb_vector/rrbt.clj:282:1)
      clojure.lang.ExceptionInfo: java.lang.IllegalArgumentException: Must hint overloaded method: toArray, compiling:(clojure/core/rrb_vector/rrbt.clj:282:1)

      Reference Travis build : https://travis-ci.org/tirkarthi/boot/jobs/398611988#L803

      This was passing a few days back but fails as of now. Feel free to close this if it's fixed in master and it's not released yet.

      Successful build : https://travis-ci.org/tirkarthi/boot/jobs/398610834

        Attachments

          Activity

            People

            • Assignee:
              michalmarczyk Michał Marczyk
              Reporter:
              xtreak Karthikeyan
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: