cljs.test/js-filename is using non-portable .endsWith

Description

.startsWith and .endsWith evidently require ECMAScript 6. (These are not on older versions of JavaScriptCore. In particular the CI tests are failing.)

A regression only on master currently with the change for CLJS-1966.

Environment

None

Assignee

David Nolen

Reporter

Mike Fikes

Labels

Approval

Accepted

Patch

Code

Fix versions

Affects versions

Priority

Major
Configure