Add invoke* helper macro

Description

This is a simple refactor around {IFn} protocol around core.cljc and core.cljs. We would like to hide the details of the invocation naming convention to avoid simple errors as well as to support changes more simply.

Environment

None

Activity

Show:
David Nolen
June 29, 2017, 8:08 PM

Looking better but lets have one helper for constructing the name, should just take number or :variadic.

Andre R
June 29, 2017, 6:29 PM

Patch updated. Much fewer changes to keep it simple for now.

David Nolen
June 29, 2017, 1:05 PM

The scope of this ticket needs to be narrowed to make it simpler for me to review. For the time being the only thing I would like to see is `invoke*` which hides the naming convention for direct invokes. No other higher level macro helpers should be provided in the resolution of this sissue.

Your pinned fields
Click on the next to a field label to start pinning.

Assignee

David Nolen

Reporter

Andre R

Labels

Approval

Screened

Patch

Code