Use consistent parameter naming in clojure.core/assoc
The clojure.core/assoc function does not seem to use consistent parameter naming, which is already used in other core functions like for example `assoc-in`, `update`, `update-in`, etc.
As the "main" function providing this functionality, I think a little extra context seems fine. I don't see this as important enough to bother with.
Attaching a patch, which makes `clojure.core/assoc` use consistent parameter naming like the rest of the core functions.