Enhance deftypes to allow fields to be marked ACC_TRANSIENT.
(deftype AType [^:transient hash])
Came across this need while experimenting with a reified range written in a deftype, not in Java.
Patch doesn't include docstring change, but has a test.
Perhaps ^:transient-mutable would be a more appropriate modifier name to be consistent with the ^:unsynchronized-mutable and ^:volatile-mutable field modifiers. In any event, this feature would eliminate the need to drop down to Java for types that require transient fields.
Roberto, there is a "Vote" word you can click on to actually vote for tickets, and ticket wranglers actually look at those votes at times to examine popular ones sooner. +1 comments don't do that.